Cisco PPPoE 設定例

Cisco ルータの PPPoE 設定例を紹介します。

PPPoE とは

PPPoE は Ethernet 上で PPP を利用するためのプロトコルで、フレッツサービスに接続する際等に使用されます。PPPoE は地域 IP 網内にある BAS とユーザ設置の Ethernet 上にあるルータ等の間でセッションを張ります。
Ethernet、PPPoE、PPP のそれぞれの特徴は次のとおりです。

  • Ethernet:マルチアクセスネットワークで AAA 機能をもたない。
  • PPPoE:Ethernet 上で仮想の Point-to-Point 回線を作成し、回線内で PPP 通信を可能にする。
  • PPP:ユーザ認証、トラフィック量管理等、AAA 機能が使用できる。

IP 通信までの流れ

PPPoE ディスカバリステージと、PPP セッションステージにより、セッションを確立します。

PPPoE ディスカバリステージ

PPP セッションステージ

Cisco PPPoE 設定例

PPPoE を利用する回線サービスに、Cisco ルータを接続する際の設定例です。

hostname Router
!
interface FastEthernet1
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 !
interface Dialer1
 mtu 1454
 ip address negotiated
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname user-a-site1@example.com
 ppp chap password cisco
 ppp ipcp dns request
 ppp ipcp route default
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
end

解説

フレッツに接続する際の注意点として、Dialer インターフェースの MRU があります。
Cisco ではデフォルトで MRU が 1500 となっており、フレッツでは、MRU が 1454 となっています。不整合のままでも接続はできますが、PPP セッションステージで、無駄なやりとりが発生します。そのため、mtu 1454 と設定することを推奨します。
よく、サンプルに ip mtu となっているのを見かけますが、これだと MRU は変更されないため、ご注意ください。

確認コマンド

PPPoE 確認

show pppoe session コマンドを実行し、State が UP となっていれば OK です。

Router#show pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A   1111  2222.2222.2222  Fa1                    Di1  Vi1        UP
                1111.1111.1111                              UP

Dialer インターフェースの状態確認

show interfacce dialer コマンドを実行し、Internet address にグローバル IP(本例では xxx.xxx.xxx.xxx/32)が付与されていれば OK です。

Router#show interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is xxx.xxx.xxx.xxx/32
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 255/255, rxload 255/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 11w3d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 207
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 529000 bits/sec, 68 packets/sec
  5 minute output rate 17610024000 bits/sec, 13 packets/sec
     665456167 packets input, 1197465197906 bytes
     356122848 packets output, 7762482682778263 bytes
<...snip...>

以上